What’s Vulnerable › Vulnerabilities
CVE-2023-29367: iSCSI Target WMI Provider Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-13 · updated 2026-06-17
- Weakness: CWE-908
Description
iSCSI Target WMI Provider Remote Code Execution Vulnerability
Affected products
- Microsoft Windows Server 2012: r2
- Microsoft Windows Server 2016: all versions
- Microsoft Windows Server 2019: all versions
- Microsoft Windows Server 2022: all versions
- Microsoft Windows Server 2012 R2: from 6.3.9600.0 before 6.3.9600.21013 — fixed in 6.3.9600.21013
- Microsoft Windows Server 2016: from 10.0.14393.0 before 10.0.14393.5989 — fixed in 10.0.14393.5989
- Microsoft Windows Server 2019: from 10.0.17763.0 before 10.0.17763.4499 — fixed in 10.0.17763.4499
- Microsoft Windows Server 2022: from 10.0.20348.0 before 10.0.20348.1787 — fixed in 10.0.20348.1787
How to fix
Upgrade to a fixed version: Microsoft Windows Server 2012 R2 6.3.9600.21013; Microsoft Windows Server 2016 10.0.14393.5989; Microsoft Windows Server 2019 10.0.17763.4499; Microsoft Windows Server 2022 10.0.20348.1787. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-29367
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-29367
Get alerted when CVE-2023-29367 or the next vulnerability affects your stack