What’s Vulnerable › Vulnerabilities
CVE-2023-29403: Unsafe behavior in setuid/setgid binaries in runtime
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-08 · updated 2026-06-17
- Weakness: CWE-668
Description
On Unix platforms, the Go runtime does not behave differently when a binary is run with the setuid/setgid bits. This can be dangerous in certain cases, such as when dumping memory state, or assuming the status of standard i/o file descriptors. If a setuid/setgid binary is executed with standard I/O file descriptors closed, opening any files can result in unexpected content being read or written with elevated privileges. Similarly, if a setuid/setgid program is terminated, either via panic or signal, it may leak the contents of its registers.
Affected products
- Fedoraproject Fedora: 38
- Go: before 1.19.10; from 1.20.0 before 1.20.5 — fixed in 1.19.10, 1.20.5
How to fix
Upgrade to a fixed version: Go 1.19.10, 1.20.5. Check the vendor advisory for mitigations.
References
- https://go.dev/cl/501223
- https://go.dev/issue/60272
- https://groups.google.com/g/golang-announce/c/q5135a9d924/m/j0ZoAJOHAwAJ
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/NZ2O6YCO2IZMZJELQGZYR2WAUNEDLYV6/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/XBS3IIK6ADV24C5ULQU55QLT2UE762ZX/
- https://pkg.go.dev/vuln/GO-2023-1840
- https://security.gentoo.org/glsa/202311-09
- https://go.dev/cl/501223
- https://go.dev/issue/60272
- https://groups.google.com/g/golang-announce/c/q5135a9d924/m/j0ZoAJOHAwAJ
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/NZ2O6YCO2IZMZJELQGZYR2WAUNEDLYV6/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/XBS3IIK6ADV24C5ULQU55QLT2UE762ZX/
Get alerted when CVE-2023-29403 or the next vulnerability affects your stack