What’s Vulnerable › Vulnerabilities
CVE-2023-29468
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-14 · updated 2026-06-17
- Weakness: CWE-120
Description
The Texas Instruments (TI) WiLink WL18xx MCP driver does not limit the number of information elements (IEs) of type XCC_EXT_1_IE_ID or XCC_EXT_2_IE_ID that can be parsed in a management frame. Using a specially crafted frame, a buffer overflow can be triggered that can potentially lead to remote code execution. This affects WILINK8-WIFI-MCP8 version 8.5_SP3 and earlier.
Affected products
- Ti Wilink8-Wifi-Mcp8: before 8.5; 8.5, 8.5-sp3 — fixed in 8.5
How to fix
Upgrade to a fixed version: Ti Wilink8-Wifi-Mcp8 8.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-29468 or the next vulnerability affects your stack