What’s Vulnerable › Vulnerabilities
CVE-2023-29510: Code injection via unescaped translations in xwiki-platform
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-19 · updated 2026-06-17
- Weakness: CWE-74
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In XWiki, every user can add translations that are only applied to the current user. This also allows overriding existing translations. Such translations are often included in privileged contexts without any escaping which allows remote code execution for any user who has edit access on at least one document which could be the user's own profile where edit access is enabled by default. A mitigation for this vulnerability is part of XWiki 14.10.2 and XWiki 15.0 RC1: translations with user scope now require script right. This means that regular users cannot exploit this anymore as users don't have script right by default anymore starting with XWiki 14.10. There are no known workarounds apart from upgrading to a patched versions.
Affected products
- xwiki-platform: before 14.10.2 — fixed in 14.10.2
How to fix
Upgrade to a fixed version: xwiki-platform 14.10.2. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/d06ff8a58480abc7f63eb1d4b8b366024d990643
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-4v38-964c-xjmw
- https://jira.xwiki.org/browse/XWIKI-19749
- https://github.com/xwiki/xwiki-platform/commit/d06ff8a58480abc7f63eb1d4b8b366024d990643
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-4v38-964c-xjmw
- https://jira.xwiki.org/browse/XWIKI-19749
Get alerted when CVE-2023-29510 or the next vulnerability affects your stack