What’s Vulnerable › Vulnerabilities
CVE-2023-29512: Code injection in xwiki-platform-web-templates
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-19 · updated 2026-06-17
- Weakness: CWE-74
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Any user with edit rights on a page (e.g., it's own user page), can execute arbitrary Groovy, Python or Velocity code in XWiki leading to full access to the XWiki installation. The root cause is improper escaping of the information loaded from attachments in `imported.vm`, `importinline.vm`, and `packagelist.vm`. This page is installed by default. This vulnerability has been patched in XWiki 15.0-rc-1, 14.10.1, 14.4.8, and 13.10.11. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- xwiki-platform: before 13.10.11; from 14.0 before 14.4.8; from 14.5 before 14.10.1 — fixed in 13.10.11, 14.10.1, 14.4.8
How to fix
Upgrade to a fixed version: xwiki-platform 13.10.11, 14.10.1, 14.4.8. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/e4bbdc23fea0be4ef1921d1a58648028ce753344
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-hg5x-3w3x-7g96
- https://jira.xwiki.org/browse/XWIKI-20267
- https://github.com/xwiki/xwiki-platform/commit/e4bbdc23fea0be4ef1921d1a58648028ce753344
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-hg5x-3w3x-7g96
- https://jira.xwiki.org/browse/XWIKI-20267
Get alerted when CVE-2023-29512 or the next vulnerability affects your stack