What’s Vulnerable › Vulnerabilities
CVE-2023-29514: Code injection in template provider administration in xwiki-platform
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-19 · updated 2026-06-17
- Weakness: CWE-74
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Any user with edit rights on any document (e.g., their own user profile) can execute code with programming rights, leading to remote code execution. This vulnerability has been patched in XWiki 13.10.11, 14.4.8, 14.10.1 and 15.0 RC1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- xwiki-platform: before 13.10.11; from 14.0 before 14.4.8; from 14.5 before 14.10.1 — fixed in 13.10.11, 14.10.1, 14.4.8
How to fix
Upgrade to a fixed version: xwiki-platform 13.10.11, 14.10.1, 14.4.8. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/7bf7094f8ffac095f5d66809af7554c9cc44de09
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-9j36-3cp4-rh4j
- https://jira.xwiki.org/browse/XWIKI-20268
- https://github.com/xwiki/xwiki-platform/commit/7bf7094f8ffac095f5d66809af7554c9cc44de09
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-9j36-3cp4-rh4j
- https://jira.xwiki.org/browse/XWIKI-20268
Get alerted when CVE-2023-29514 or the next vulnerability affects your stack