What’s Vulnerable › Vulnerabilities
CVE-2023-29519: Code injection in org.xwiki.platform:xwiki-platform-attachment-ui
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-19 · updated 2026-06-17
- Weakness: CWE-74
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. A registered user can perform remote code execution leading to privilege escalation by injecting the proper code in the "property" field of an attachment selector, as a gadget of their own dashboard. Note that the vulnerability does not impact comments of a wiki. The vulnerability has been patched in XWiki 13.10.11, 14.4.8, 14.10.2, 15.0-rc-1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- xwiki-platform: before 13.10.11; from 14.0 before 14.4.8; from 14.5 before 14.10.2 — fixed in 13.10.11, 14.10.2, 14.4.8
How to fix
Upgrade to a fixed version: xwiki-platform 13.10.11, 14.10.2, 14.4.8. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/5e8725b4272cd3e5be09d3ca84273be2da6869c1
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-3hjg-cghv-22ww
- https://jira.xwiki.org/browse/XWIKI-20364
- https://github.com/xwiki/xwiki-platform/commit/5e8725b4272cd3e5be09d3ca84273be2da6869c1
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-3hjg-cghv-22ww
- https://jira.xwiki.org/browse/XWIKI-20364
Get alerted when CVE-2023-29519 or the next vulnerability affects your stack