What’s Vulnerable › Vulnerabilities
CVE-2023-29527: Code injection from account through AWM view sheet in xwiki platform
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-19 · updated 2026-06-17
- Weakness: CWE-74
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In affected versions a user without script or programming right may edit a user profile (or any other document) with the wiki editor and add groovy script content. Viewing the document after saving it will execute the groovy script in the server context which provides code execution. This vulnerability has been patched in XWiki 15.0-rc-1 and 14.10.3. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- xwiki-platform: from 7.4.4 before 14.10.3 — fixed in 14.10.3
How to fix
Upgrade to a fixed version: xwiki-platform 14.10.3. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-jgrg-qvpp-9vwr
- https://jira.xwiki.org/browse/XWIKI-20423
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-jgrg-qvpp-9vwr
- https://jira.xwiki.org/browse/XWIKI-20423
Get alerted when CVE-2023-29527 or the next vulnerability affects your stack