What’s Vulnerable › Vulnerabilities
CVE-2023-29528: Cross-site Scripting in org.xwiki.commons:xwiki-commons-xml
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-20 · updated 2026-06-17
- Weakness: CWE-79
Description
XWiki Commons are technical libraries common to several other top level XWiki projects. The "restricted" mode of the HTML cleaner in XWiki, introduced in version 4.2-milestone-1 and massively improved in version 14.6-rc-1, allowed the injection of arbitrary HTML code and thus cross-site scripting via invalid HTML comments. As a consequence, any code relying on this "restricted" mode for security is vulnerable to JavaScript injection ("cross-site scripting"/XSS). When a privileged user with programming rights visits such a comment in XWiki, the malicious JavaScript code is executed in the context of the user session. This allows server-side code execution with programming rights, impacting the confidentiality, integrity and availability of the XWiki instance. This problem has been patched in XWiki 14.10, HTML comments are now removed in restricted mode and a check has been introduced that ensures that comments don't start with `>`. There are no known workarounds apart from upgrading to a version including the fix.
Affected products
- xwiki Commons: from 4.3 before 14.10; 4.2, 4.2-milestone1, 4.2-milestone2, 4.2-milestone3, 4.2-rc1 — fixed in 14.10
How to fix
Upgrade to a fixed version: xwiki Commons 14.10. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-commons/commit/8ff1a9d7e5d7b45b690134a537d53dc05cae04ab
- https://github.com/xwiki/xwiki-commons/security/advisories/GHSA-x37v-36wv-6v6h
- https://jira.xwiki.org/browse/XCOMMONS-2568
- https://jira.xwiki.org/browse/XWIKI-20348
- https://github.com/xwiki/xwiki-commons/commit/8ff1a9d7e5d7b45b690134a537d53dc05cae04ab
- https://github.com/xwiki/xwiki-commons/security/advisories/GHSA-x37v-36wv-6v6h
- https://jira.xwiki.org/browse/XCOMMONS-2568
- https://jira.xwiki.org/browse/XWIKI-20348
Get alerted when CVE-2023-29528 or the next vulnerability affects your stack