What’s Vulnerable › Vulnerabilities
CVE-2023-29530: Laminas Diactoros vulnerable to HTTP Multiline Header Termination
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-24 · updated 2026-06-17
- Weakness: CWE-20
Description
Laminas Diactoros provides PSR HTTP Message implementations. In versions 2.18.0 and prior, 2.19.0, 2.20.0, 2.21.0, 2.22.0, 2.23.0, 2.24.0, and 2.25.0, users who create HTTP requests or responses using laminas/laminas-diactoros, when providing a newline at the start or end of a header key or value, can cause an invalid message. This can lead to denial of service vectors or application errors. The problem has been patched in following versions 2.18.1, 2.19.1, 2.20.1, 2.21.1, 2.22.1, 2.23.1, 2.24.1, and 2.25.1. As a workaround, validate HTTP header keys and/or values, and if using user-supplied values, filter them to strip off leading or trailing newline characters before calling `withHeader()`.
Affected products
- Fedoraproject Fedora: 38
- laminas-diactoros: before 2.18.1; 2.19.0, 2.20.0, 2.21.0, 2.22.0, 2.23.0, 2.24.0 (+1) — fixed in 2.18.1
- Guzzlephp Psr-7: before 1.9.1; from 2.0.0 before 2.4.5 — fixed in 1.9.1, 2.4.5
How to fix
Upgrade to a fixed version: laminas-diactoros 2.18.1; Guzzlephp Psr-7 1.9.1, 2.4.5. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-wxmh-65f7-jcvw
- https://github.com/laminas/laminas-diactoros/security/advisories/GHSA-xv3h-4844-9h36
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/BPW54QK7ISDALPLP2CKODU4ZIVRYS336/
- https://github.com/advisories/GHSA-wxmh-65f7-jcvw
- https://github.com/laminas/laminas-diactoros/security/advisories/GHSA-xv3h-4844-9h36
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/BPW54QK7ISDALPLP2CKODU4ZIVRYS336/
Get alerted when CVE-2023-29530 or the next vulnerability affects your stack