What’s Vulnerable › Vulnerabilities
CVE-2023-2996: Jetpack < 12.1.1 - Author+ Arbitrary File Manipulation via API
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-27 · updated 2026-06-17
Description
The Jetpack WordPress plugin before 12.1.1 does not validate uploaded files, allowing users with author roles or above to manipulate existing files on the site, deleting arbitrary files, and in rare cases achieve Remote Code Execution via phar deserialization.
Affected products
- Jetpack: before 12.1.1 — fixed in 12.1.1
How to fix
Upgrade to a fixed version: Jetpack 12.1.1. Check the vendor advisory for mitigations.
References
- https://jetpack.com/blog/jetpack-12-1-1-critical-security-update/
- https://wpscan.com/vulnerability/52d221bd-ae42-435d-a90a-60a5ae530663
- https://jetpack.com/blog/jetpack-12-1-1-critical-security-update/
- https://wpscan.com/vulnerability/52d221bd-ae42-435d-a90a-60a5ae530663
Get alerted when CVE-2023-2996 or the next vulnerability affects your stack