What’s Vulnerable › Vulnerabilities
CVE-2023-3011: ARMember <= 4.0.5 - Cross-Site Request Forgery
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-12 · updated 2026-06-17
- Weakness: CWE-352
Description
The ARMember plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 4.0.5. This is due to missing or incorrect nonce validation on the arm_check_user_cap function. This makes it possible for unauthenticated attackers to perform multiple unauthorized actions via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- reputeinfosystems ARMember – Membership Plugin, Content Restriction, Member Levels, User Profile & User signup: before 4.0.6 — fixed in 4.0.6
How to fix
Upgrade to a fixed version: reputeinfosystems ARMember – Membership Plugin, Content Restriction, Member Levels, User Profile & User signup 4.0.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2932691/armember-membership/trunk/autoload.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/42f5f29b-2d83-4b15-82aa-0598f8a2317b?source=cve
- https://plugins.trac.wordpress.org/changeset/2932691/armember-membership/trunk/autoload.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/42f5f29b-2d83-4b15-82aa-0598f8a2317b?source=cve
Get alerted when CVE-2023-3011 or the next vulnerability affects your stack