What’s Vulnerable › Vulnerabilities

CVE-2023-30149

Description

SQL injection vulnerability in the City Autocomplete (cityautocomplete) module from ebewe.net for PrestaShop, prior to version 1.8.12 (for PrestaShop version 1.5/1.6) or prior to 2.0.3 (for PrestaShop version 1.7), allows remote attackers to execute arbitrary SQL commands via the type, input_name. or q parameter in the autocompletion.php front controller.

Affected products

How to fix

Upgrade to a fixed version: Ebewe City Autocomplete 1.8.12, 2.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-30149 or the next vulnerability affects your stack