What’s Vulnerable › Vulnerabilities
CVE-2023-30153
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-18 · updated 2026-06-17
- Weakness: CWE-89
Description
An SQL injection vulnerability in the Payplug (payplug) module for PrestaShop, in versions 3.6.0, 3.6.1, 3.6.2, 3.6.3, 3.7.0 and 3.7.1, allows remote attackers to execute arbitrary SQL commands via the ajax.php front controller.
Affected products
- PrestaShop Payplug: from 3.6.0 before 3.8.2 — fixed in 3.8.2
How to fix
Upgrade to a fixed version: PrestaShop Payplug 3.8.2. Check the vendor advisory for mitigations.
References
- https://addons.prestashop.com/en/payment-card-wallet/8795--payplug-accept-customer-payments-wherever-they-are.html
- https://security.friendsofpresta.org/module/2023/07/18/payplug.html
- https://addons.prestashop.com/en/payment-card-wallet/8795--payplug-accept-customer-payments-wherever-they-are.html
- https://security.friendsofpresta.org/module/2023/07/18/payplug.html
Get alerted when CVE-2023-30153 or the next vulnerability affects your stack