What’s Vulnerable › Vulnerabilities
CVE-2023-30154
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-14 · updated 2026-06-17
- Weakness: CWE-89
Description
Multiple improper neutralization of SQL parameters in module AfterMail (aftermailpresta) for PrestaShop, before version 2.2.1, allows remote attackers to perform SQL injection attacks via `id_customer`, `id_conf`, `id_product` and `token` parameters in `aftermailajax.php via the 'id_product' parameter in hooks DisplayRightColumnProduct and DisplayProductButtons.
Affected products
- Shoprunners Aftermail: before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: Shoprunners Aftermail 2.2.1. Check the vendor advisory for mitigations.
References
- https://security.friendsofpresta.org/modules/2023/10/10/aftermailpresta.html
- https://security.friendsofpresta.org/modules/2023/10/10/aftermailpresta.html
Get alerted when CVE-2023-30154 or the next vulnerability affects your stack