What’s Vulnerable › Vulnerabilities
CVE-2023-3020: Cross-site Scripting (XSS) - Reflected in mkucej/i-librarian-free
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in GitHub repository mkucej/i-librarian-free prior to 5.10.4.
Affected products
- Scilicot I, Librarian: before 5.10.4 — fixed in 5.10.4
How to fix
Upgrade to a fixed version: Scilicot I, Librarian 5.10.4. Check the vendor advisory for mitigations.
References
- https://github.com/mkucej/i-librarian-free/commit/3f2c64768a70fc0d529bc29d47bc706ecf26314e
- https://huntr.dev/bounties/92cbe37c-33fa-43bf-8d5b-69aebf51d32c
- https://github.com/mkucej/i-librarian-free/commit/3f2c64768a70fc0d529bc29d47bc706ecf26314e
- https://huntr.dev/bounties/92cbe37c-33fa-43bf-8d5b-69aebf51d32c
Get alerted when CVE-2023-3020 or the next vulnerability affects your stack