What’s Vulnerable › Vulnerabilities
CVE-2023-30200
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-20 · updated 2026-06-17
- Weakness: CWE-22
Description
In the module “Image: WebP, Compress, Zoom, Lazy load, Alt & More” (ultimateimagetool) in versions up to 2.1.02 from Advanced Plugins for PrestaShop, a guest can download personal informations without restriction by performing a path traversal attack.
Affected products
- Advancedplugins Ultimateimagetool: before 2.1.03 — fixed in 2.1.03
How to fix
Upgrade to a fixed version: Advancedplugins Ultimateimagetool 2.1.03. Check the vendor advisory for mitigations.
References
- https://github.com/PrestaShop/PrestaShop/blob/6c05518b807d014ee8edb811041e3de232520c28/classes/Tools.php#L1247
- https://security.friendsofpresta.org/modules/2023/07/20/ultimateimagetool.html
- https://github.com/PrestaShop/PrestaShop/blob/6c05518b807d014ee8edb811041e3de232520c28/classes/Tools.php#L1247
- https://security.friendsofpresta.org/modules/2023/07/20/ultimateimagetool.html
Get alerted when CVE-2023-30200 or the next vulnerability affects your stack