What’s Vulnerable › Vulnerabilities
CVE-2023-3021: Cross-site Scripting (XSS) - Stored in mkucej/i-librarian-free
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository mkucej/i-librarian-free prior to 5.10.4.
Affected products
- Scilico I, Librarian: before 5.10.4 — fixed in 5.10.4
How to fix
Upgrade to a fixed version: Scilico I, Librarian 5.10.4. Check the vendor advisory for mitigations.
References
- https://github.com/mkucej/i-librarian-free/commit/187e5ff4f413047fb522a9ab24c3c42555d7cfe7
- https://huntr.dev/bounties/9d289d3a-2931-4e94-b61c-449581736eff
- https://github.com/mkucej/i-librarian-free/commit/187e5ff4f413047fb522a9ab24c3c42555d7cfe7
- https://huntr.dev/bounties/9d289d3a-2931-4e94-b61c-449581736eff
Get alerted when CVE-2023-3021 or the next vulnerability affects your stack