What’s Vulnerable › Vulnerabilities
CVE-2023-30362
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-23 · updated 2026-06-17
- Weakness: CWE-125
Description
Buffer Overflow vulnerability in coap_send function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu.
Affected products
- libcoap: before 4.3.1-120-ge242200 — fixed in 4.3.1-120-ge242200
How to fix
Upgrade to a fixed version: libcoap 4.3.1-120-ge242200. Check the vendor advisory for mitigations.
References
- https://github.com/obgm/libcoap/issues/1063
- https://github.com/obgm/libcoap/pull/1065
- https://github.com/obgm/libcoap/issues/1063
- https://github.com/obgm/libcoap/pull/1065
Get alerted when CVE-2023-30362 or the next vulnerability affects your stack