What’s Vulnerable › Vulnerabilities
CVE-2023-30429: Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-12 · updated 2026-06-17
- Weakness: CWE-863
Description
Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar. This issue affects Apache Pulsar: before 2.10.4, and 2.11.0. When a client connects to the Pulsar Function Worker via the Pulsar Proxy where the Pulsar Proxy uses mTLS authentication to authenticate with the Pulsar Function Worker, the Pulsar Function Worker incorrectly performs authorization by using the Proxy's role for authorization instead of the client's role, which can lead to privilege escalation, especially if the proxy is configured with a superuser role. The recommended mitigation for impacted users is to upgrade the Pulsar Function Worker to a patched version. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.4. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.1. 3.0 Pulsar Function Worker users are unaffected. Any users running the Pulsar Function Worker for 2.9.* and earlier should upgrade to one of the above patched versions.
Affected products
- Apache Software Foundation Apache Pulsar: before 2.10.4; 2.11.0, 2.11.0-candidate_1, 2.11.0-candidate_5 — fixed in 2.10.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Pulsar 2.10.4. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/v0gcvvxswr830314q4b1kybsfmcf3jf8
- https://lists.apache.org/thread/v0gcvvxswr830314q4b1kybsfmcf3jf8
Get alerted when CVE-2023-30429 or the next vulnerability affects your stack