What’s Vulnerable › Vulnerabilities
CVE-2023-30581
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-23 · updated 2026-06-17
- Weakness: CWE-862
Description
The use of __proto__ in process.mainModule.__proto__.require() can bypass the policy mechanism and require modules outside of the policy.json definition. This vulnerability affects all users using the experimental policy mechanism in all active release lines: v16, v18 and, v20. Please note that at the time this CVE was issued, the policy is an experimental feature of Node.js
Affected products
- Node.js: from 16.0.0 before 16.20.1; from 18.0.0 before 18.16.1; from 20.0.0 before 20.3.1 — fixed in 16.20.1, 18.16.1, 20.3.1
How to fix
Upgrade to a fixed version: Node.js 16.20.1, 18.16.1, 20.3.1. Check the vendor advisory for mitigations.
References
- https://nodejs.org/en/blog/vulnerability/june-2023-security-releases
- https://nodejs.org/en/blog/vulnerability/june-2023-security-releases
- https://security.netapp.com/advisory/ntap-20241101-0011/
Get alerted when CVE-2023-30581 or the next vulnerability affects your stack