What’s Vulnerable › Vulnerabilities
CVE-2023-30587
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-07 · updated 2026-06-17
- Weakness: CWE-284
Description
A vulnerability in Node.js version 20 allows for bypassing restrictions set by the --experimental-permission flag using the built-in inspector module (node:inspector). By exploiting the Worker class's ability to create an "internal worker" with the kIsInternal Symbol, attackers can modify the isInternal value when an inspector is attached within the Worker constructor before initializing a new WorkerImpl. This vulnerability exclusively affects Node.js users employing the permission model mechanism. Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.
Affected products
- nodejs: from 20.0 before 20.3.1 — fixed in 20.3.1
How to fix
Upgrade to a fixed version: nodejs 20.3.1. Check the vendor advisory for mitigations.
References
- https://nodejs.org/en/blog/vulnerability/june-2023-security-releases
- https://security.netapp.com/advisory/ntap-20241108-0004/
Get alerted when CVE-2023-30587 or the next vulnerability affects your stack