What’s Vulnerable › Vulnerabilities
CVE-2023-30588
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-28 · updated 2026-06-17
Description
When an invalid public key is used to create an x509 certificate using the crypto.X509Certificate() API a non-expect termination occurs making it susceptible to DoS attacks when the attacker could force interruptions of application processing, as the process terminates when accessing public key info of provided certificates from user code. The current context of the users will be gone, and that will cause a DoS scenario. This vulnerability affects all active Node.js versions v16, v18, and, v20.
Affected products
- Node.js: from 16.0.0 before 16.20.1; from 18.0.0 before 18.16.1; from 20.0.0 before 20.3.1 — fixed in 16.20.1, 18.16.1, 20.3.1
How to fix
Upgrade to a fixed version: Node.js 16.20.1, 18.16.1, 20.3.1. Check the vendor advisory for mitigations.
References
- https://nodejs.org/en/blog/vulnerability/june-2023-security-releases
- https://security.netapp.com/advisory/ntap-20240621-0006/
- https://nodejs.org/en/blog/vulnerability/june-2023-security-releases
- https://security.netapp.com/advisory/ntap-20240621-0006/
- https://security.netapp.com/advisory/ntap-20241101-0011/
Get alerted when CVE-2023-30588 or the next vulnerability affects your stack