What’s Vulnerable › Vulnerabilities
CVE-2023-30606: Multisite denial of service through unsanitized dynamic dispatch to SiteSetting in Discourse
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-18 · updated 2026-06-17
- Weakness: CWE-732
Description
Discourse is an open source platform for community discussion. In affected versions a user logged as an administrator can call arbitrary methods on the `SiteSetting` class, notably `#clear_cache!` and `#notify_changed!`, which when done on a multisite instance, can affect the entire cluster resulting in a denial of service. Users not running in multisite environments are not affected. This issue is patched in the latest stable, beta and tests-passed versions of Discourse. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- discourse: through 3.0.1; before 3.1.0; 3.1.0-beta1, 3.1.0-beta2 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: discourse 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/security/advisories/GHSA-jj93-w3mv-3jvv
- https://github.com/discourse/discourse/security/advisories/GHSA-jj93-w3mv-3jvv
Get alerted when CVE-2023-30606 or the next vulnerability affects your stack