What’s Vulnerable › Vulnerabilities
CVE-2023-30614: Improper Neutralization of Script-Related HTML Tags in a Web Page in pay
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Pay is a payments engine for Ruby on Rails 6.0 and higher. In versions prior to 6.3.2 a payments info page of Pay is susceptible to reflected Cross-site scripting. An attacker could create a working URL that renders a javascript link to a user on a Rails application that integrates Pay. This URL could be distributed via email to specifically target certain individuals. If the targeted application contains a functionality to submit user-generated content (such as comments) the attacker could even distribute the URL using that functionality. This has been patched in version 6.3.2 and above. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- pay-rails pay: before 6.3.2 — fixed in 6.3.2
How to fix
Upgrade to a fixed version: pay-rails pay 6.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/pay-rails/pay/commit/5d6283a24062bd272a524ec48415f536a67ad57f
- https://github.com/pay-rails/pay/security/advisories/GHSA-cqf3-vpx7-rxhw
- https://github.com/pay-rails/pay/commit/5d6283a24062bd272a524ec48415f536a67ad57f
- https://github.com/pay-rails/pay/security/advisories/GHSA-cqf3-vpx7-rxhw
Get alerted when CVE-2023-30614 or the next vulnerability affects your stack