What’s Vulnerable › Vulnerabilities
CVE-2023-30615: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in iris-web
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-25 · updated 2026-06-17
- Weakness: CWE-80
Description
Iris is a web collaborative platform aiming to help incident responders sharing technical details during investigations. A stored Cross-Site Scripting (XSS) vulnerability has been identified in iris-web, affecting multiple locations . The vulnerability in allows an attacker to inject malicious scripts into the application, which are then executed when a user visits the affected locations. This can lead to unauthorized access, data theft, or other malicious activities. An attacker need to be authenticated on the application to exploit this vulnerability. The issue was patched in version 2.2.1 of iris-web.
Affected products
- dfir-iris iris-web: before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: dfir-iris iris-web 2.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/dfir-iris/iris-web/releases/tag/v2.2.1
- https://github.com/dfir-iris/iris-web/security/advisories/GHSA-gc6j-6276-2m49
- https://github.com/dfir-iris/iris-web/releases/tag/v2.2.1
- https://github.com/dfir-iris/iris-web/security/advisories/GHSA-gc6j-6276-2m49
Get alerted when CVE-2023-30615 or the next vulnerability affects your stack