What’s Vulnerable › Vulnerabilities
CVE-2023-30616: Cross Site Request Forgery due to missing nonce verification in form block
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-20 · updated 2026-06-17
- Weakness: CWE-352
Description
Form block is a wordpress plugin designed to make form creation easier. Versions prior to 1.0.2 are subject to a Cross-Site Request Forgery due to a missing nonce check. There is potential for a Cross Site Request Forgery for all form blocks, since it allows to send requests to the forms from any website without a user noticing. Users are advised to upgrade to version 1.0.2. There are no known workarounds for this vulnerability.
Affected products
- epiphyt Form Block: before 1.0.2 — fixed in 1.0.2
How to fix
Upgrade to a fixed version: epiphyt Form Block 1.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/epiphyt/form-block/commit/cf0012fa0710d906c594346ba775c5dc433a9426
- https://github.com/epiphyt/form-block/security/advisories/GHSA-j4c2-7p87-q824
- https://github.com/epiphyt/form-block/commit/cf0012fa0710d906c594346ba775c5dc433a9426
- https://github.com/epiphyt/form-block/security/advisories/GHSA-j4c2-7p87-q824
Get alerted when CVE-2023-30616 or the next vulnerability affects your stack