What’s Vulnerable › Vulnerabilities
CVE-2023-30626: Jellyfin vulnerable to directory traversal and file write causing arbitrary code execution
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-24 · updated 2026-06-17
- Weakness: CWE-22
Description
Jellyfin is a free-software media system. Versions starting with 10.8.0 and prior to 10.8.10 and prior have a directory traversal vulnerability inside the `ClientLogController`, specifically `/ClientLog/Document`. When combined with a cross-site scripting vulnerability (CVE-2023-30627), this can result in file write and arbitrary code execution. Version 10.8.10 has a patch for this issue. There are no known workarounds.
Affected products
- jellyfin: from 10.8.0 before 10.8.10 — fixed in 10.8.10
How to fix
Upgrade to a fixed version: jellyfin 10.8.10. Check the vendor advisory for mitigations.
References
- https://github.com/jellyfin/jellyfin-web/security/advisories/GHSA-89hp-h43h-r5pq
- https://github.com/jellyfin/jellyfin/blob/22d880662283980dec994cd7d35fe269613bfce3/Jellyfin.Api/Controllers/ClientLogController.cs#L44
- https://github.com/jellyfin/jellyfin/commit/82ad2633fdfb1c37a158057c7935f83e1129eda7
- https://github.com/jellyfin/jellyfin/pull/5918
- https://github.com/jellyfin/jellyfin/releases/tag/v10.8.10
- https://github.com/jellyfin/jellyfin/security/advisories/GHSA-9p5f-5x8v-x65m
- https://github.com/jellyfin/jellyfin-web/security/advisories/GHSA-89hp-h43h-r5pq
- https://github.com/jellyfin/jellyfin/blob/22d880662283980dec994cd7d35fe269613bfce3/Jellyfin.Api/Controllers/ClientLogController.cs#L44
- https://github.com/jellyfin/jellyfin/commit/82ad2633fdfb1c37a158057c7935f83e1129eda7
- https://github.com/jellyfin/jellyfin/pull/5918
- https://github.com/jellyfin/jellyfin/releases/tag/v10.8.10
- https://github.com/jellyfin/jellyfin/security/advisories/GHSA-9p5f-5x8v-x65m
Get alerted when CVE-2023-30626 or the next vulnerability affects your stack