What’s Vulnerable › Vulnerabilities
CVE-2023-30627: jellyfin-web has a stored cross-site scripting vulnerability in devices.js
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-24 · updated 2026-06-17
- Weakness: CWE-79
Description
jellyfin-web is the web client for Jellyfin, a free-software media system. Starting in version 10.1.0 and prior to version 10.8.10, a stored cross-site scripting vulnerability in device.js can be used to make arbitrary calls to the `REST` endpoints with admin privileges. When combined with CVE-2023-30626, this results in remote code execution on the Jellyfin instance in the context of the user who's running it. This issue is patched in version 10.8.10. There are no known workarounds.
Affected products
- jellyfin: from 10.1.0 before 10.8.10 — fixed in 10.8.10
How to fix
Upgrade to a fixed version: jellyfin 10.8.10. Check the vendor advisory for mitigations.
References
- https://github.com/jellyfin/jellyfin-web/commit/b88a5951e1a517ff4c820e693d9c0da981cf68ee
- https://github.com/jellyfin/jellyfin-web/releases/tag/v10.8.10
- https://github.com/jellyfin/jellyfin-web/security/advisories/GHSA-89hp-h43h-r5pq
- https://github.com/jellyfin/jellyfin/security/advisories/GHSA-9p5f-5x8v-x65m
- https://github.com/jellyfin/jellyfin-web/commit/b88a5951e1a517ff4c820e693d9c0da981cf68ee
- https://github.com/jellyfin/jellyfin-web/releases/tag/v10.8.10
- https://github.com/jellyfin/jellyfin-web/security/advisories/GHSA-89hp-h43h-r5pq
- https://github.com/jellyfin/jellyfin/security/advisories/GHSA-9p5f-5x8v-x65m
Get alerted when CVE-2023-30627 or the next vulnerability affects your stack