What’s Vulnerable › Vulnerabilities
CVE-2023-3067: Cross-site Scripting (XSS) - Stored in zadam/trilium
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-02 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository zadam/trilium prior to 0.59.4.
Affected products
- zadam/trilium: before 0.59.3 — fixed in 0.59.3
How to fix
Upgrade to a fixed version: zadam/trilium 0.59.3. Check the vendor advisory for mitigations.
References
- https://github.com/zadam/trilium/commit/4c3fcc3ea6f37debcb87ac1a7f5698c27be0e67b
- https://huntr.dev/bounties/4772ceb7-1594-414d-9b20-5b82029da7b6
- https://github.com/zadam/trilium/commit/4c3fcc3ea6f37debcb87ac1a7f5698c27be0e67b
- https://huntr.dev/bounties/4772ceb7-1594-414d-9b20-5b82029da7b6
Get alerted when CVE-2023-3067 or the next vulnerability affects your stack