What’s Vulnerable › Vulnerabilities
CVE-2023-3077: MStore API < 3.9.8 - Unauthenticated Blind SQLi
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-10 · updated 2026-06-17
Description
The MStore API WordPress plugin before 3.9.8 does not sanitise and escape a parameter before using it in a SQL statement, leading to a Blind SQL injection exploitable by unauthenticated users. This is only exploitable if the site owner elected to pay to get access to the plugins' pro features, and uses the woocommerce-appointments plugin.
Affected products
- inspireui MStore API – Create Native Android & iOS Apps On The Cloud: before 3.9.8 — fixed in 3.9.8
How to fix
Upgrade to a fixed version: inspireui MStore API – Create Native Android & iOS Apps On The Cloud 3.9.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9480d0b5-97da-467d-98f6-71a32599a432
- https://wpscan.com/vulnerability/9480d0b5-97da-467d-98f6-71a32599a432
Get alerted when CVE-2023-3077 or the next vulnerability affects your stack