What’s Vulnerable › Vulnerabilities
CVE-2023-30780: WordPress User IP and Location Plugin <= 2.2 is vulnerable to Cross Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in TheGuideX User IP and Location plugin <= 2.2 versions.
Affected products
- TheGuideX User IP and Location: before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: TheGuideX User IP and Location 2.2.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/user-ip-and-location/wordpress-user-ip-and-location-plugin-2-2-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/user-ip-and-location/wordpress-user-ip-and-location-plugin-2-2-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2023-30780 or the next vulnerability affects your stack