What’s Vulnerable › Vulnerabilities
CVE-2023-3079: Google Chromium V8 Type Confusion Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2023-06-07
- EPSS: 37.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-05 · updated 2026-10-08
- Weakness: CWE-843
Description
Type confusion in V8 in Google Chrome prior to 114.0.5735.110 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)
Affected products
- Couchbase Server: before 7.1.5; 7.2.0 — fixed in 7.1.5
- Debian Linux: 11.0, 12.0
- Fedoraproject Fedora: 37, 38
- Google Chrome: before 114.0.5735.110 — fixed in 114.0.5735.110
How to fix
Upgrade to a fixed version: Couchbase Server 7.1.5; Google Chrome 114.0.5735.110. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/176211/Chrome-V8-Type-Confusion.html
- http://packetstormsecurity.com/files/176212/Chrome-V8-Type-Confusion-New-Sandbox-Escape.html
- https://chromereleases.googleblog.com/2023/06/stable-channel-update-for-desktop.html
- https://crbug.com/1450481
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DYTXO5E3FI3I2ETDP3HF4SHYYTFMKMIC/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/U4OXTNIZY4JYHJT7CVLPAJQILI6BISVM/
- https://security.gentoo.org/glsa/202311-11
- https://security.gentoo.org/glsa/202401-34
- https://www.couchbase.com/alerts/
- https://www.debian.org/security/2023/dsa-5420
- http://packetstormsecurity.com/files/176211/Chrome-V8-Type-Confusion.html
- http://packetstormsecurity.com/files/176212/Chrome-V8-Type-Confusion-New-Sandbox-Escape.html
Get alerted when CVE-2023-3079 or the next vulnerability affects your stack