What’s Vulnerable › Vulnerabilities
CVE-2023-3080: WP Mail Catcher <= 2.1.2 - Unauthenticated Stored Cross-Site Scripting via Email Subject
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Mail Catcher plugin for WordPress is vulnerable to Stored Cross-Site Scripting via an email subject in versions up to, and including, 2.1.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- James Ward Mail logging – WP Mail Catcher: before 2.1.3 — fixed in 2.1.3
How to fix
Upgrade to a fixed version: James Ward Mail logging – WP Mail Catcher 2.1.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2924014/wp-mail-catcher
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1525e1c9-4b94-4f9f-92c5-fc69fe000771?source=cve
- https://plugins.trac.wordpress.org/changeset/2924014/wp-mail-catcher
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1525e1c9-4b94-4f9f-92c5-fc69fe000771?source=cve
Get alerted when CVE-2023-3080 or the next vulnerability affects your stack