What’s Vulnerable › Vulnerabilities
CVE-2023-3082: Post SMTP <= 2.5.7 - Unauthenticated Stored Cross-Site Scripting via Email
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Post SMTP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via email contents in versions up to, and including, 2.5.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- saadiqbal Post SMTP – Complete Email Deliverability and SMTP Solution with Email Logs, Alerts, Backup SMTP & Mobile App: before 2.5.8 — fixed in 2.5.8
How to fix
Upgrade to a fixed version: saadiqbal Post SMTP – Complete Email Deliverability and SMTP Solution with Email Logs, Alerts, Backup SMTP & Mobile App 2.5.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2935537/post-smtp
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6ecd0fa6-4fdb-4780-9560-0bb126800685?source=cve
- https://plugins.trac.wordpress.org/changeset/2935537/post-smtp
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6ecd0fa6-4fdb-4780-9560-0bb126800685?source=cve
Get alerted when CVE-2023-3082 or the next vulnerability affects your stack