What’s Vulnerable › Vulnerabilities
CVE-2023-30838: PrestaShop vulnerable to possible XSS injection through Validate::isCleanHTML method
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-25 · updated 2026-06-17
- Weakness: CWE-79
Description
PrestaShop is an Open Source e-commerce web application. Prior to versions 8.0.4 and 1.7.8.9, the `ValidateCore::isCleanHTML()` method of Prestashop misses hijackable events which can lead to cross-site scripting (XSS) injection, allowed by the presence of pre-setup `@keyframes` methods. This XSS, which hijacks HTML attributes, can be triggered without any interaction by the visitor/administrator, which makes it as dangerous as a trivial XSS attack. Contrary to other attacks which target HTML attributes and are triggered without user interaction (such as onload / onerror which suffer from a very limited scope), this one can hijack every HTML element, which increases the danger due to a complete HTML elements scope. Versions 8.0.4 and 1.7.8.9 contain a fix for this issue.
Affected products
- PrestaShop: before 1.7.8.9; from 8.0.0 before 8.0.4 — fixed in 1.7.8.9, 8.0.4
How to fix
Upgrade to a fixed version: PrestaShop 1.7.8.9, 8.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/PrestaShop/PrestaShop/commit/46408ae4b02f3b8b1bb6e9dc63af5bcd858abd9c
- https://github.com/PrestaShop/PrestaShop/commit/dc682192df0e4b0d656a8e645b29ca1b9dbe3693
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-fh7r-996q-gvcp
- https://github.com/PrestaShop/PrestaShop/commit/46408ae4b02f3b8b1bb6e9dc63af5bcd858abd9c
- https://github.com/PrestaShop/PrestaShop/commit/dc682192df0e4b0d656a8e645b29ca1b9dbe3693
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-fh7r-996q-gvcp
Get alerted when CVE-2023-30838 or the next vulnerability affects your stack