What’s Vulnerable › Vulnerabilities
CVE-2023-30839: PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager"
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-25 · updated 2026-06-17
- Weakness: CWE-89
Description
PrestaShop is an Open Source e-commerce web application. Versions prior to 8.0.4 and 1.7.8.9 contain a SQL filtering vulnerability. A BO user can write, update, and delete in the database, even without having specific rights. PrestaShop 8.0.4 and 1.7.8.9 contain a patch for this issue. There are no known workarounds.
Affected products
- PrestaShop: before 1.7.8.9; from 8.0.0 before 8.0.4 — fixed in 1.7.8.9, 8.0.4
How to fix
Upgrade to a fixed version: PrestaShop 1.7.8.9, 8.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/PrestaShop/PrestaShop/commit/0f2a9b7fdd42d1dd3b21d4fad586a849642f3c30
- https://github.com/PrestaShop/PrestaShop/commit/d1d27dc371599713c912b71bc2a455cacd7f2149
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-p379-cxqh-q822
- https://github.com/PrestaShop/PrestaShop/commit/0f2a9b7fdd42d1dd3b21d4fad586a849642f3c30
- https://github.com/PrestaShop/PrestaShop/commit/d1d27dc371599713c912b71bc2a455cacd7f2149
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-p379-cxqh-q822
Get alerted when CVE-2023-30839 or the next vulnerability affects your stack