What’s Vulnerable › Vulnerabilities
CVE-2023-30848: Pimcore SQL Injection Vulnerability in Admin Search Find API
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-27 · updated 2026-06-17
- Weakness: CWE-89
Description
Pimcore is an open source data and experience management platform. Prior to version 10.5.21, the admin search find API has a SQL injection vulnerability. Users should upgrade to version 10.5.21 to receive a patch or, as a workaround, apply the patch manually.
Affected products
- pimcore/pimcore: before 10.5.21 — fixed in 10.5.21
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.5.21. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/25ad8674886f2b938243cbe13e33e204a2e35cc3.patch
- https://github.com/pimcore/pimcore/pull/14972
- https://github.com/pimcore/pimcore/security/advisories/GHSA-6mhm-gcpf-5gr8
- https://github.com/pimcore/pimcore/commit/25ad8674886f2b938243cbe13e33e204a2e35cc3.patch
- https://github.com/pimcore/pimcore/pull/14972
- https://github.com/pimcore/pimcore/security/advisories/GHSA-6mhm-gcpf-5gr8
Get alerted when CVE-2023-30848 or the next vulnerability affects your stack