What’s Vulnerable › Vulnerabilities
CVE-2023-30849: Pimcore vulnerable to SQL Injection in Translation Export API
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-27 · updated 2026-06-17
- Weakness: CWE-89
Description
Pimcore is an open source data and experience management platform. Prior to version 10.5.21, A SQL injection vulnerability exists in the translation export API. Users should update to version 10.5.21 to receive a patch or, as a workaround, or apply the patch manually.
Affected products
- pimcore/pimcore: before 10.5.21 — fixed in 10.5.21
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.5.21. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/c6c80905e58c7724c776f980570a56df7016c6d1.patch
- https://github.com/pimcore/pimcore/pull/14968
- https://github.com/pimcore/pimcore/security/advisories/GHSA-xmg8-w465-mr56
- https://github.com/pimcore/pimcore/commit/c6c80905e58c7724c776f980570a56df7016c6d1.patch
- https://github.com/pimcore/pimcore/pull/14968
- https://github.com/pimcore/pimcore/security/advisories/GHSA-xmg8-w465-mr56
Get alerted when CVE-2023-30849 or the next vulnerability affects your stack