What’s Vulnerable › Vulnerabilities
CVE-2023-3085: X-WRT luci 404 Error Template dispatcher.uc run_action cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-03 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability, which was classified as problematic, has been found in X-WRT luci up to 22.10_b202303061504. This issue affects the function run_action of the file modules/luci-base/ucode/dispatcher.uc of the component 404 Error Template Handler. The manipulation of the argument request_path leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 22.10_b202303121313 is able to address this issue. The patch is named 24d7da2416b9ab246825c33c213fe939a89b369c. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230663.
Affected products
- X-WRT luci: before 22.10_b202303121313 — fixed in 22.10_b202303121313
How to fix
Upgrade to a fixed version: X-WRT luci 22.10_b202303121313. Check the vendor advisory for mitigations.
References
- https://github.com/x-wrt/luci/commit/24d7da2416b9ab246825c33c213fe939a89b369c
- https://github.com/x-wrt/luci/releases/tag/22.10_b202303121313
- https://vuldb.com/?ctiid.230663
- https://vuldb.com/?id.230663
- https://github.com/x-wrt/luci/commit/24d7da2416b9ab246825c33c213fe939a89b369c
- https://github.com/x-wrt/luci/releases/tag/22.10_b202303121313
- https://vuldb.com/?ctiid.230663
- https://vuldb.com/?id.230663
Get alerted when CVE-2023-3085 or the next vulnerability affects your stack