What’s Vulnerable › Vulnerabilities
CVE-2023-30858: Denosaurs emoji has ReDoS vulnerability in `replace` function
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-28 · updated 2026-06-17
- Weakness: CWE-1333
Description
The Denosaurs emoji package provides emojis for dinosaurs. Starting in version 0.1.0 and prior to version 0.3.0, the reTrimSpace regex has 2nd degree polynomial inefficiency, leading to a delayed response given a big payload. The issue has been patched in 0.3.0. As a workaround, avoid using the `replace`, `unemojify`, or `strip` functions.
Affected products
- denosaurs emoji: from 0.1.0 before 0.3.0 — fixed in 0.3.0
How to fix
Upgrade to a fixed version: denosaurs emoji 0.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/denosaurs/emoji/pull/11
- https://github.com/denosaurs/emoji/security/advisories/GHSA-w2xx-hjhp-gx5v
- https://huntr.dev/bounties/444f2255-5085-466f-ba0e-5549fa8846a3/
- https://github.com/denosaurs/emoji/pull/11
- https://github.com/denosaurs/emoji/security/advisories/GHSA-w2xx-hjhp-gx5v
- https://huntr.dev/bounties/444f2255-5085-466f-ba0e-5549fa8846a3/
Get alerted when CVE-2023-30858 or the next vulnerability affects your stack