What’s Vulnerable › Vulnerabilities
CVE-2023-30943: Moodle: tinymce loaders susceptible to arbitrary folder creation
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-02 · updated 2026-06-17
- Weakness: CWE-73
Description
The vulnerability was found Moodle which exists because the application allows a user to control path of the older to create in TinyMCE loaders. A remote user can send a specially crafted HTTP request and create arbitrary folders on the system.
Affected products
- Fedoraproject Extra Packages For Enterprise Linux: 7.0
- Fedoraproject Fedora: 36, 37, 38
- Moodle: from 4.1.0 before 4.1.3 — fixed in 4.1.3
How to fix
Upgrade to a fixed version: Moodle 4.1.3. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-77718
- https://bugzilla.redhat.com/show_bug.cgi?id=2188605
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/54TM5H5PDUDYXOQ7X7PPYWP4AJDAE73I/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MZBWRVUJF7HI53XCJPJ3YJZPOV5HBRUY/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PBFSXRYLT4ICKJVQSRBAOUDMDRVSVBLS/
- https://moodle.org/mod/forum/discuss.php?d=446285
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-77718
- https://bugzilla.redhat.com/show_bug.cgi?id=2188605
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/54TM5H5PDUDYXOQ7X7PPYWP4AJDAE73I/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MZBWRVUJF7HI53XCJPJ3YJZPOV5HBRUY/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PBFSXRYLT4ICKJVQSRBAOUDMDRVSVBLS/
- https://moodle.org/mod/forum/discuss.php?d=446285
Get alerted when CVE-2023-30943 or the next vulnerability affects your stack