What’s Vulnerable › Vulnerabilities
CVE-2023-30967: Gotham Orbital Simulator path traversal
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-26 · updated 2026-06-17
- Weakness: CWE-22
Description
Gotham Orbital-Simulator service prior to 0.692.0 was found to be vulnerable to a Path traversal issue allowing an unauthenticated user to read arbitrary files on the file system.
Affected products
- Palantir com.palantir.meta:orbital-simulator: before 0.692.0 — fixed in 0.692.0
How to fix
Upgrade to a fixed version: Palantir com.palantir.meta:orbital-simulator 0.692.0. Check the vendor advisory for mitigations.
References
- https://palantir.safebase.us/?tcuUid=8fd5809f-26f8-406e-b36f-4a6596a19d79
- https://palantir.safebase.us/?tcuUid=8fd5809f-26f8-406e-b36f-4a6596a19d79
Get alerted when CVE-2023-30967 or the next vulnerability affects your stack