What’s Vulnerable › Vulnerabilities
CVE-2023-31039: Apache bRPC: ServerOptions.pid_file may cause arbitrary code execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-08 · updated 2026-10-24
- Weakness: CWE-20
Description
Security vulnerability in Apache bRPC <1.5.0 on all platforms allows attackers to execute arbitrary code via ServerOptions::pid_file. An attacker that can influence the ServerOptions pid_file parameter with which the bRPC server is started can execute arbitrary code with the permissions of the bRPC process. Solution: 1. upgrade to bRPC >= 1.5.0, download link: https://dist.apache.org/repos/dist/release/brpc/1.5.0/ https://dist.apache.org/repos/dist/release/brpc/1.5.0/ 2. If you are using an old version of bRPC and hard to upgrade, you can apply this patch: https://github.com/apache/brpc/pull/2218 https://github.com/apache/brpc/pull/2218
Affected products
- Apache Software Foundation Apache bRPC: from 0.9.0 before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache bRPC 1.5.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/05/08/1
- https://lists.apache.org/thread/jqpttrqbc38yhckgp67xk399hqxnz7jn
- http://www.openwall.com/lists/oss-security/2023/05/08/1
- https://lists.apache.org/thread/jqpttrqbc38yhckgp67xk399hqxnz7jn
Get alerted when CVE-2023-31039 or the next vulnerability affects your stack