What’s Vulnerable › Vulnerabilities

CVE-2023-31043

Description

EnterpriseDB EDB Postgres Advanced Server (EPAS) before 14.6.0 logs unredacted passwords in situations where optional parameters are used with CREATE/ALTER USER/GROUP/ROLE, and redacting was configured with edb_filter_log.redact_password_commands. The fixed versions are 10.23.33, 11.18.29, 12.13.17, 13.9.13, and 14.6.0.

Affected products

How to fix

Upgrade to a fixed version: EnterpriseDB Postgres Advanced Server 10.23.33, 11.18.29, 12.13.17, 13.9.13. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-31043 or the next vulnerability affects your stack