What’s Vulnerable › Vulnerabilities
CVE-2023-31062: Apache InLong: Privilege escalation vulnerability for InLong
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-22 · updated 2026-06-17
- Weakness: CWE-269
Description
Improper Privilege Management Vulnerabilities in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.2.0 through 1.6.0. When the attacker has access to a valid (but unprivileged) account, the exploit can be executed using Burp Suite by sending a login request and following it with a subsequent HTTP request using the returned cookie. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 https://github.com/apache/inlong/pull/7836 to solve it.
Affected products
- Apache Software Foundation Apache InLong: from 1.2.0 through 1.6.0
References
- https://lists.apache.org/thread/btorjbo9o71h22tcvxzy076022hjdzq0
- https://lists.apache.org/thread/btorjbo9o71h22tcvxzy076022hjdzq0
Get alerted when CVE-2023-31062 or the next vulnerability affects your stack