What’s Vulnerable › Vulnerabilities
CVE-2023-31065: Apache InLong: Insufficient Session Expiration in InLong
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-22 · updated 2026-06-17
- Weakness: CWE-613
Description
Insufficient Session Expiration vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.6.0. An old session can be used by an attacker even after the user has been deleted or the password has been changed. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 https://github.com/apache/inlong/pull/7836 , https://github.com/apache/inlong/pull/7884 https://github.com/apache/inlong/pull/7884 to solve it.
Affected products
- Apache Software Foundation Apache InLong: from 1.4.0 through 1.6.0
References
- https://lists.apache.org/thread/to7o0n2cks0omtwo6mhh5cs2vfdbplqf
- https://lists.apache.org/thread/to7o0n2cks0omtwo6mhh5cs2vfdbplqf
Get alerted when CVE-2023-31065 or the next vulnerability affects your stack