What’s Vulnerable › Vulnerabilities
CVE-2023-31094: WordPress Stock Sync for WooCommerce Plugin <= 2.4.0 is vulnerable to Cross Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Lauri Karisola / WP Trio Stock Sync for WooCommerce plugin <= 2.4.0 versions.
Affected products
- Lauri Karisola / WP Trio Stock Sync for WooCommerce: before 2.4.1 — fixed in 2.4.1
How to fix
Upgrade to a fixed version: Lauri Karisola / WP Trio Stock Sync for WooCommerce 2.4.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/stock-sync-for-woocommerce/wordpress-stock-sync-for-woocommerce-plugin-2-4-0-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/stock-sync-for-woocommerce/wordpress-stock-sync-for-woocommerce-plugin-2-4-0-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2023-31094 or the next vulnerability affects your stack