What’s Vulnerable › Vulnerabilities
CVE-2023-31131: Arbitrary File Write when Extracting Tarballs in greenplum-db
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-15 · updated 2026-06-17
- Weakness: CWE-22
Description
Greenplum Database (GPDB) is an open source data warehouse based on PostgreSQL. In versions prior to 6.22.3 Greenplum Database used an unsafe methods to extract tar files within GPPKGs. greenplum-db is vulnerable to path traversal leading to arbitrary file writes. An attacker can use this vulnerability to overwrite data or system files potentially leading to crash or malfunction of the system. Any files which are accessible to the running process are at risk. All users are requested to upgrade to Greenplum Database version 6.23.2 or higher. There are no known workarounds for this vulnerability.
Affected products
- VMware Greenplum Database: before 6.22.3 — fixed in 6.22.3
- greenplum-db gpdb: before 6.22.3
How to fix
Upgrade to a fixed version: VMware Greenplum Database 6.22.3. Check the vendor advisory for mitigations.
References
- https://github.com/greenplum-db/gpdb/commit/1ec4affbba7c9745f64edbd80a6680ad29b09471
- https://github.com/greenplum-db/gpdb/security/advisories/GHSA-hgm9-2q42-c7f3
- https://github.com/greenplum-db/gpdb/commit/1ec4affbba7c9745f64edbd80a6680ad29b09471
- https://github.com/greenplum-db/gpdb/security/advisories/GHSA-hgm9-2q42-c7f3
Get alerted when CVE-2023-31131 or the next vulnerability affects your stack