What’s Vulnerable › Vulnerabilities
CVE-2023-31142: Discourse's general category permissions could be set back to default
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-13 · updated 2026-06-17
- Weakness: CWE-732
Description
Discourse is an open source discussion platform. Prior to version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches, if a site has modified their general category permissions, they could be set back to the default. This issue is patched in version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches. A workaround, only if you are modifying the general category permissions, is to use a new category for the same purpose.
Affected products
- discourse: before 3.0.4; 3.1.0-beta1, 3.1.0-beta2, 3.1.0-beta3, 3.1.0-beta4 — fixed in 3.0.4
How to fix
Upgrade to a fixed version: discourse 3.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/security/advisories/GHSA-286w-97m2-78x2
- https://github.com/discourse/discourse/security/advisories/GHSA-286w-97m2-78x2
Get alerted when CVE-2023-31142 or the next vulnerability affects your stack